MULTI: Getting Started
DISCLAIMER

GREEN HILLS SOFTWARE, INC., MAKES NO REPRESENTATIONS OR WARRANTIES WITH RESPECT TO THE CONTENTS HEREOF AND SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. Further, Green Hills Software, Inc., reserves the right to revise this publication and to make changes from time to time in the content hereof without obligation of Green Hills Software, Inc., to notify any person of such revision or changes.

Copyright © 1983-2005 by Green Hills Software, Inc. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, recording, or otherwise, without prior written permission from Green Hills Software, Inc.


All other company, product, or service names mentioned in this book may be trademarks or service marks of their respective owners.

PubID: 10387
October 20, 2005
Contents

1 Introduction 1
   The MULTI Integrated Development Environment 2
   The MULTI Launcher 4
      MULTI Workspaces 5
   The MULTI 4.0 Document Set 6
   Online Help
      Viewing Help on Windows Systems 7
      Viewing Help on UNIX Systems 8
   Conventions Used in This Book 9

2 Installation and Licensing 11
   Windows System Requirements 12
   Linux System Requirements 12
   Solaris System Requirements 13
   HP-UX System Requirements 13
   Windows QuickStart 14
   UNIX QuickStart 15
   Licensing Overview
      Obtaining an Evaluation License 17

3 MULTI Tutorial 19
   Starting MULTI 20
   Creating Your First Project 20
   Building Your Program 22
   Starting the Debugger 23
   Connecting to a Simulator 24
   Debugging Your Program 24
   Connecting to Your Target Hardware 25
   Setting Up a Workspace
      Creating a Workspace 26
      Adding Actions 27
   Additional Examples 29
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index</td>
</tr>
</tbody>
</table>

MULTI: Getting Started
Chapter 1

Introduction

This Chapter Contains:

- The MULTI Integrated Development Environment
- The MULTI Launcher
- The MULTI 4.0 Document Set
- Online Help
- Conventions Used in This Book
This chapter provides an overview of the MULTI Integrated Development Environment and its documentation set.

The MULTI Integrated Development Environment

MULTI is a complete Integrated Development Environment (IDE) designed especially for embedded systems engineers to assist them in analyzing, editing, compiling, optimizing, and debugging embedded applications.

The MULTI IDE includes graphical tools for each part of the software development process. The following tools can be launched from within the IDE or as separate stand-alone programs:

• IDE launcher
  - MULTI Launcher (mstart) — The gateway to the MULTI IDE, which allows you to quickly launch any of the primary MULTI tools, access open windows, and manage MULTI workspaces

• Editing tools
  - MULTI Editor (me) — A graphical editor for modifying text files
  - Checkout Browser (mcobrowse) — A graphical viewer for files managed under a version control system
  - Diff Viewer (diffview) — A graphical viewer that displays differences between two text files
  - Hex Editor (mhexedit) — A graphical editor for modifying binary files

• Building tools
  - MULTI Builder (mbuild) — A graphical interface for managing and building projects
  - CodeBalance (codebalance) — A graphical interface for automating the process of optimizing an executable for size or speed
  - INTEGRATE (integrate) — A graphical utility for configuring tasks, connections, and kernel objects across multiple address spaces when using the INTEGRITY RTOS
  - Linker Directives File Editor (mldedit) — A graphical editor for creating and modifying linker directives files
• **Debugging tools**
  
  - **MULTI Debugger (multi)** — A graphical source-level debugger
  - **EventAnalyzer (mevgui)** — A graphical viewer for monitoring the complex real-time interactions of an embedded RTOS such as INTEGRITY or ThreadX
  - **ResourceAnalyzer (wperf)** — A graphical viewer for monitoring the CPU and memory usage of an embedded system running the INTEGRITY RTOS
  - **Script Debugger (mscriptdbg)** — A graphical debugger for writing, recording, and debugging scripts containing MULTI commands
  - **Serial Terminal (mterminal)** — A serial terminal emulator for connecting to serial ports on embedded devices

• **Miscellaneous and administrative tools**
  
  - **Bug Report (gbugrpt)** — A utility for providing system configuration and tool version information to the Green Hills support staff
  - **Green Hills Probe Administrator (gpadmin)** — A graphical interface for configuring and managing Green Hills Debug Probes (Slingshots, Green Hills Probes, and/or SuperTrace Probes)
  - **Graphical Utilities (wgutils)** — A collection of utilities for analyzing and performing various operations on object files, libraries, and executables produced with the Green Hills toolchain
  - **MULTI License Administrator (mlmadmin)** — A graphical utility for managing Green Hills tools licenses
1. Introduction

The MULTI Launcher

The MULTI Launcher (mstart) provides a convenient way to launch frequently used tools, to create new or access recently used files and projects, and to manage MULTI workspaces. All of the main MULTI components can be accessed using the following buttons:

- ![Shortcut or action sequence](image)
  — Runs a shortcut or an action sequence in the current workspace. Also allows you to create a new workspace or create or edit a shortcut.

- ![Project](image)
  — Opens the Builder on a recent or new project.

- ![Executable](image)
  — Opens the Debugger on a recent or new executable.

- ![File](image)
  — Opens the Editor on a recent or new file.

- ![Checkout](image)
  — Opens the Checkout Browser on a recent or new checkout.

- ![Connection](image)
  — Opens the Connection Organizer or a recent or new target connection.

- ![Terminal](image)
  — Opens a Serial Terminal using a recent or new connection.

- ![Event](image)
  — Opens the EventAnalyzer (licensed separately).

- ![Resource](image)
  — Opens the ResourceAnalyzer (licensed separately).

- ![Close](image)
  — Closes the MULTI Launcher (UNIX only by default).

- ![Visibility](image)
  — Shows/hides the detail pane of the Launcher.

You can also launch the Green Hills License Administrator and (if installed) the Green Hills Probe Administrator from the Utilities menu.

During development, you can use the MULTI Launcher as a convenient centralized window manager. You can access any of your open MULTI windows from the Windows menu of the Launcher.
MULTI Workspaces

The MULTI Launcher allows you to create and use workspaces. A MULTI workspace is a virtual area where the tools, files, and actions required for a particular project can be organized, accessed, and executed.

A workspace is typically created for each top-level project and includes a working directory and a group of related actions — for example, opening a project in the MULTI Builder, connecting to a target, or performing a shell command. Actions are grouped into action sequences, so that a single mouse click can perform all the actions in the specified action sequence.

For more information, see Chapter 5, “Using MULTI Workspaces and Shortcuts” in the MULTI: Editing Files and Configuring the IDE book.
The MULTI 4.0 Document Set

The primary documentation for using MULTI is provided in the following books:

- **MULTI: Getting Started** — Describes how to install MULTI and obtain a license, and takes you through creating, building, and debugging an example project.
- **MULTI: Editing Files and Configuring the IDE** — Describes how to use the MULTI Editor, how to use a version control system with MULTI, how to use the MULTI Launcher, and how to configure and license the MULTI IDE.
- **MULTI: Building Applications** — Describes how to use the MULTI Builder and compiler drivers and the tools that compile, assemble, and link your code. Also describes the Green Hills implementation of supported high-level languages.
- **MULTI: Configuring Connections** — Describes how to set up your target debugging interface for use with MULTI and how to configure connections to your target.
- **MULTI: Debugging** — Describes how to use the MULTI Debugger and its associated tools.

These books, and any others you may have received (for example, for the INTEGRITY or ThreadX operating system, or for the Green Hills Debug Probes) are available in the following formats:

- A printed book
- Online help, accessible from most MULTI windows via the Help → Manuals menu (see “Online Help” on page 7)
- An electronic PDF, available in the manuals subdirectory of your installation

**Note** New or updated information may have become available while this book was in production. For additional material that was not available at press time, or for revisions that may have become necessary since this book was printed, please check your CD-ROM for Release Notes, README files, and other supplementary documentation.
Online Help

The MULTI online help system provides three different types of online help:

- **Full online manuals** — You can access an indexed hypertext version of any MULTI manual by selecting it from the list that appears in the Help → Manuals menu.

- **Context-sensitive help** — Many MULTI windows and dialog boxes are linked to specific sections of the online manuals. To view the page in online help that documents an active window or dialog box:
  - (Windows) Press F1.
  - (UNIX) Press F1 or Help.

If you are using the MULTI Editor, you can also open context-sensitive help about a button or a menu item by selecting Help → Identify and then clicking the button or selecting the menu item.

- **Debugger command help** — You can obtain help information about a specific MULTI Debugger command by typing `help command_name` in the Debugger command pane. This will open the online version of the MULTI: Debugging book on the section that documents the specified command. You can also type `usage command_name` to print to the command pane the basic syntax of the specified command.

Viewing Help on Windows Systems

Windows systems display online help via the Microsoft HTML Help viewer. You can view only one manual at a time with the HTML Help viewer.

There are two panes in the HTML Help viewer. The right-hand pane displays the contents of a selected help page. You can click any underlined link that appears in right-hand pane to jump to pages about other related topics. The left-hand pane provides the following three navigation tabs:

- **Contents** — Displays the chapter and section headings for the manual being viewed. Click a plus or minus icon to show or hide headings for embedded sections. Click a heading to display the associated help page in the right-hand pane.

- **Index** — Displays index entries for the manual. Double-click an index entry to display its help page in the right-hand pane.
• **Search** — Provides an interface that allows you to search for specific words in the manual. Enter a word or phrase in the text box and click **List Topics** to display a list of pages related to your search string. Double-click any entry in the list to display the entry’s help page in the right-hand pane.

### Viewing Help on UNIX Systems

Depending on your specific UNIX system, MULTI will automatically choose one of the following two methods for viewing online help:

• **Oracle Help for Java** — Displays hypertext version of manuals, including tables of contents and index entries, and provides full text searching across multiple manuals, with the ability to sort and rank search results.

This viewer may take up to 30 seconds to initialize and is only available on systems running Red Hat Linux 7.1 or higher, Solaris 2.6 or higher, or HP-UX 10.20 or 11.x. Other UNIX systems must use browser-based online help. If problems occur when MULTI is attempting to start the Oracle Help for Java application, you will see a message prompting you to use browser-based help (see below).

The Java Runtime Environment that is included with MULTI has been configured to use fonts common to most X Window servers. However, some X Window servers may not display Oracle Help for Java properly. To configure fonts for the Java Runtime Environment, edit the `font.properties` file that is located in the `jre/lib` directory of your MULTI installation (for more information, see the Sun Microsystems Java web site).

• **Web Browser Help** — Displays hypertext version of manuals, including tables of contents and index entries. In GUI mode, `netscape` is the default browser. If `netscape` is installed on your system and the executable is in your path, no further configuration should be necessary. In non-GUI mode, a copy of `lynx` running inside of an `xterm` will be used as the default browser. If you have `xterm` in your path, no further configuration should be necessary.

For information about using an alternate web browser, see “Using a Custom Web Browser with UNIX” in Chapter 8, “Configuring and Customizing MULTI” in the *MULTI: Editing Files and Configuring the IDE* book.

**Note** To change your online help settings, choose **Config → Options → General** tab, then click **Help**.
Conventions Used in This Book

All Green Hills documentation assumes that you have a working knowledge of your host operating system and its conventions, including its command line and graphical user interface (GUI) modes. For example, you should know how to use basic commands, how to open, save, and close files, and how to use a mouse and standard menus.

Green Hills documentation uses a variety of notational conventions to present information and describe procedures. These conventions are described below.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>bold type</strong></td>
<td>Indicates a:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Filename or pathname</td>
<td>• C:\MyProjects</td>
</tr>
<tr>
<td></td>
<td>• Command</td>
<td>• setup command</td>
</tr>
<tr>
<td></td>
<td>• Option</td>
<td>• -G option</td>
</tr>
<tr>
<td></td>
<td>• Window title</td>
<td>• the Task window</td>
</tr>
<tr>
<td></td>
<td>• Button name</td>
<td>• the Browse button</td>
</tr>
<tr>
<td></td>
<td>• Menu name or menu choice</td>
<td>• the File menu</td>
</tr>
<tr>
<td><strong>italic type</strong></td>
<td>Indicates that the user should replace the text in italics with an</td>
<td>-o filename</td>
</tr>
<tr>
<td></td>
<td>appropriate argument, command, filename, or other value.</td>
<td></td>
</tr>
<tr>
<td>**ellipsis (…)</td>
<td>Indicates that the preceding argument or option can be repeated zero or</td>
<td>debugbutton [name]…</td>
</tr>
<tr>
<td>(in command line</td>
<td>more times.</td>
<td></td>
</tr>
<tr>
<td>instructions)</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>greater than sign</strong></td>
<td>Represents a prompt. Your actual prompt may be a different symbol or</td>
<td>&gt; print Test</td>
</tr>
<tr>
<td>(&gt;)</td>
<td>string. The &gt; prompt helps to distinguish input from output in examples</td>
<td>Test</td>
</tr>
<tr>
<td></td>
<td>of screen displays.</td>
<td></td>
</tr>
</tbody>
</table>
1. Introduction

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>pipe (</td>
<td>) (in command line instructions)</td>
<td>Indicates that one (and only one) of the parameters or options separated by the pipe or pipes should be specified.</td>
</tr>
<tr>
<td>square brackets ([ ]) (in command line instructions)</td>
<td>Indicate optional arguments, commands, options, and so on. You can either include or omit the enclosed elements. The square brackets should not appear in your actual command.</td>
<td>.macro name [list]</td>
</tr>
</tbody>
</table>

The following command description demonstrates the use of some of these typographical conventions.

**gxyz [-option]… filename**

The formatting of this command indicates that:

- The command **gxyz** should be entered as shown.
- The option **-option** should either be replaced with one or more appropriate options or be omitted.
- The word **filename** should be replaced with the actual filename of an appropriate file.

The square brackets and the ellipsis should not appear in the actual command you enter.
Chapter 2

Installation and Licensing

This Chapter Contains:

- Windows System Requirements
- Linux System Requirements
- Solaris System Requirements
- HP-UX System Requirements
- Windows QuickStart
- UNIX QuickStart
- Licensing Overview
This chapter provides “QuickStart” installation and licensing instructions, which will have most users up and running straight away. If you require more information about licensing, see Part IV, “License Administration” of the *MULTI: Editing Files and Configuring the IDE* book.

## Windows System Requirements

Green Hills Software products require:

- A minimum of a 700 MHz Pentium processor and 256 MB of RAM. We recommend a 1.4 GHz Pentium processor and 512 MB of RAM.
- A 256-color display, at a minimum resolution of 1024x768. We recommend a minimum resolution of 1280x1024.
- An Ethernet connection.
- 500-1000 MB of free disk space per installation. If an older version of MULTI is already installed on your machine, then you should install this version in a different directory. If installing to a drive other than your primary Windows drive, you must also have at least 10 MB available on the primary drive for temporary files and DLLs.
- A CD-ROM drive.
- Internet Explorer 3.01 or later (to view online help).
- Microsoft Windows 98, NT 4.0, ME, 2000, or XP.

## Linux System Requirements

Green Hills Software products require:

- A minimum of a 700 MHz Pentium processor and 256 MB of RAM. We recommend at least a 1.4 GHz Pentium processor and 512 MB of RAM.
- Red Hat Linux 7.0-7.3, 8.0, 9.0, or Enterprise. Linux products that are compatible with these Red Hat releases should work, but are not officially supported. For example, Debian GNU/Linux 2.x and Caldera OpenLinux 2.2 and 3.1 are known to work.
- 500–1000 MB of free disk space per installation.
- A 256-color display, at a minimum resolution of 1024x768. We recommend a 256-color display at a minimum resolution of 1280x1024.
Solaris System Requirements

Green Hills Software products require:

- A Solaris 2.5-2.9 SPARC-based workstation with at least 256 MB of physical memory.
- 500–1000 MB of free disk space per installation.
- A graphical display running the X Windowing System.
- An Ethernet connection.
- A mounted CD-ROM drive.

HP-UX System Requirements

Green Hills Software products require:

- An HP-UX 10.20 or 11.x workstation with at least 256 MB of physical memory.
- 500–1000 MB of free disk space per installation.
- A graphical display running the X Windowing System.
- An Ethernet connection.
- A mounted CD-ROM drive.
2. Installation and Licensing

Windows QuickStart

To install and begin using MULTI on a Windows machine:

1. Close all other programs and insert the MULTI CD. If it does not autorun, then open the drive in Windows Explorer and double-click `setup.exe`. The InstallShield Wizard will open.

2. Click Next to view the Setup Options screen, which displays the default installation settings. To install MULTI with the default settings, click Next. To change any of these default settings, click the Customize button, follow the instructions until you reach the summary screen, and then click Next to install MULTI.

3. When all the files have been installed, a dialog may open asking you to specify the directory where your embedded operating system distribution is installed. If you are developing for an OS, then follow the instructions to specify the installation directory.

4. A dialog may open asking you to select product updates to install. These may include the Native x86 Windows tools (which require a separate license to use) and any patches that are recommended for this MULTI distribution. Select any updates that you want to install and click Next.

5. When all the updates have installed, the final setup screen will open. Click Finish to complete the installation.

6. Double-click the MULTI icon on your desktop to open the MULTI Launcher.

If you are upgrading from a previous version of MULTI, then you will probably be able to use your old license and to begin developing immediately. If you are a new user or you are otherwise unable to obtain a license, then a dialog will open listing the license servers available on your network and allowing you to choose to request licenses from them. For a general introduction to licensing MULTI, see “Licensing Overview” on page 17. For detailed information, see Chapter 11, “License Administration with the MULTI License Administrator” in the MULTI: Editing Files and Configuring the IDE book.
UNIX QuickStart

To install and begin using MULTI on a Linux, Solaris, or HP-UX machine:

1. Insert the MULTI CD and run `setup_linux86`, `setup_solaris2`, or `setup_hppa`. The Installer GUI will open on its Introduction screen.

   **Note** If long filenames (such as `setup_solaris2` or `setup_hppa`) are truncated when you list the contents of your Green Hills CD, you will not be able to install directly from the CD. The problem may be that your CD ROM drive does not support Rock Ridge or Joliet extensions to the ISO 9660 file system standard. To work around this problem, mount these CDs from a system that supports the Joliet or Rock Ridge extensions (such as Windows or Linux). Configure that machine to make the CD available to the target machine (via NFS or Samba, or by copying the files to a network drive), then run the tools in that directory from any machine.

2. Click Next to open the Install Type tab, which allows you to specify the installation of any or all of the following:
   - MULTI Integrated Development Environment
   - Remote Serial Terminal Connection Server
   - Licensing Utilities

3. Click Next to open the Components screen, which allows you to specify the installation of Documentation (online help and PDFs) and/or Tools.

4. Click Next to open the General tab, which allows you to specify an installation directory and host operating system. By default, MULTI will install into one of the following directories:
   - For Linux — `/usr/green/linux86`
   - For Solaris — `/usr/green/solaris2`
   - For HP-UX — `/usr/green/hppa`

5. Click Next to open the Target Architecture screen, which allows you to specify your target processor family. You may also select to install native tools (which require a separate license to use) and any patches that are recommended for this MULTI distribution.

6. Click Next to open the Summary screen, which lists your installation selections. Click Install to begin installing files.
7. When the file transfer has completed, click **Finish** to complete the installation.

8. Run **multi** from your installation directory to open the MULTI Launcher.

   If you are upgrading from a previous version of MULTI, then you will probably be able to use your old license and to begin developing immediately. If you are a new user or you are otherwise unable to obtain a license, then a dialog will open listing the license servers available on your network and allowing you to choose to request licenses from them. For a general introduction to licensing MULTI, see “Licensing Overview” on page 17. For detailed information, see Chapter 11, “License Administration with the **MULTI License Administrator**” in the *MULTI: Editing Files and Configuring the IDE* book.
Licensing Overview

MULTI is a licensed application, and you will need to acquire a license before you can begin using it. If you are upgrading from an earlier version of MULTI, then your existing licenses remain valid, and you should be able to begin developing immediately.

Green Hills provides four different licensing models:

- **Native License Server** — A PC or workstation on your network acts as a license server that manages the following types of licenses. Your system administrator must obtain licenses from Green Hills before you can begin using MULTI.

  - **Named-User Licenses** — Licenses are purchased for each individual user of MULTI. Each user will only ever require one license, even if they are running more than one copy of MULTI concurrently.

  - **Floating Licenses** — Licenses are purchased for each instance of MULTI that you want to run concurrently. A single user will require one license for each instance of MULTI that he or she is running concurrently.

To request floating or named-user licenses for a native license server, log on to the machine that will act as your license server and open the MULTI Launcher. Select Utilities → License Administrator to open the MULTI License Administrator. Select Request a license from Green Hills, click Next, and follow the instructions to generate a license request. Many license requests can be fulfilled in a matter of minutes, and most will be completed within one working day.

- **Computer-Locked Licenses** — (Windows only) Licenses are purchased and installed on particular machines. Any number of instances of MULTI may be run concurrently on any machine that possesses a license. The procedure for requesting a license is the same as for the Native License Server model, but you must request the license from the machine that it will be locked to.

- **Dongle-locked Licenses** — (Windows only) Licenses are purchased and held ondongles, which are hardware security devices that plug into a PC’s USB or parallel port. Any number of instances of MULTI may be run concurrently on any machine to which a dongle is attached. The procedure for requesting a license is the same as for the Native License Server model, but you request the license from a machine to which the dongle is attached.
2. Installation and Licensing

For more information about licensing, see Part IV, “License Administration” of the *MULTI: Editing Files and Configuring the IDE* book.

**Obtaining an Evaluation License**

If you are installing an evaluation copy of MULTI, you will probably need to request a license from Green Hills. To do this, log on to the machine where the licenses will be installed and follow these steps:

1. Open the MULTI Launcher.
2. Select **Utilities → License Administrator** to open the **MULTI License Administrator**.
3. Select **Request a license from Green Hills** and click **Next**.
4. Follow the remaining on screen instructions to send a license request to Green Hills.
Chapter 3

MULTI Tutorial

This Chapter Contains:

- Starting MULTI
- Creating Your First Project
- Building Your Program
- Starting the Debugger
- Connecting to a Simulator
- Debugging Your Program
- Connecting to Your Target Hardware
- Setting Up a Workspace
- Additional Examples
This chapter introduces you to the basic components of the MULTI IDE, and leads you through creating and building a simple “Hello World” program. You will then run and debug this program on both a simulator and your target hardware.

### Starting MULTI

The MULTI Launcher is the primary entry point to the MULTI IDE. It provides a convenient way to access your files and projects, and all of the main MULTI components. Use one of the following methods to start the Launcher.

- (Windows) — Double-click the shortcut titled MULTI which was placed on your desktop during installation.
- (UNIX) — Ensure the MULTI installation directory is in your path. Run `multi`.

Before exploring the Launcher in detail, we will create a project and associated files for it to manage.

### Creating Your First Project

A project is a collection of source code and resource files which is used to build one or more programs or libraries. Projects are created using the New Project Wizard. Follow the steps below to create the Hello World project used for the remainder of this tutorial.

1. Start the Launcher as described above.

2. Click the button and select Create Project to open the New Project Wizard.

3. On the first screen, you are asked to enter information about your target board. On the left-hand side, you should select a Processor Family and an Operating System. On the right-hand side, you should select the board that you are developing for. If your board is not listed or if you have not yet
decided on one, you should expand the **Generic Processor** list and select the processor you intend to target.

When you have finished selecting your target board, click **Next**.

4. On the next screen, you are asked to enter information about the project you are creating. The project types that have an “Example” prefix walk you through particular features of the MULTI Debugger. Others are skeleton projects for you to use in creating a project for your source code.

Select **Executable (Hello World)** from the **Project type** list and click **Finish**.

## Building Your Program

The **New Project Wizard** creates all the files necessary for the **Hello World** project, and opens it in the MULTI Builder.

The project is ready to build. Click **Build** to build the executable program, **hello**. You can follow the progress of the build in the **Output** pane at the bottom of the Builder window.

For more information about the MULTI Builder, see Chapter 2, “The MULTI Builder” in the *MULTI: Building Applications* book.
Starting the Debugger

Now that your project is built, click \(\text{(Debug)}\) to open the MULTI Debugger on the \textit{hello} executable.

For more information about the MULTI Debugger, see Part I, “Basic Debugging” in the \textit{MULTI: Debugging} book.
Connecting to a Simulator

Before you can debug the program in the MULTI Debugger, you must connect to a hardware target or simulator which will run the program. The simulators provide an easy-to-use platform to develop and debug your application before you begin working with actual hardware. Perform the following steps to connect to a Green Hills simulator:

1. Click (Connect) on the MULTI Debugger toolbar to open the Connection Chooser.

2. The New Project Wizard creates several Connection Methods for your target board as part of your project. Select the simulator connection from the drop-down list and click Connect.

For more information about connecting to a target, see Chapter 3, “Connecting to Your Target” in the MULTI: Debugging book.

Debugging Your Program

Now that you are connected to the simulator, you can step through your code, use breakpoints, view registers and memory, and perform many other debug tasks with the MULTI Debugger.

Try the following basic debugging techniques:

- To step into the program, click (Step (F11)) on the Debugger toolbar.

Note MULTI will automatically download your program to the target when you first begin executing the code. This process will be nearly instantaneous on the simulator but may take a few moments when you are connected to a target board.
Connecting to Your Target Hardware

Earlier, you connected to a simulator to debug your program. Now, use the following steps to connect to your target board:

1. If you are still connected to the simulator, disconnect from it by clicking on the MULTI Debugger toolbar.
2. Connect your target board to the host computer via a debug device or serial cable, depending on which protocol you will be using to debug your board.
3. Click to open the Connection Chooser.
4. Select the Connection Method corresponding to your debug device from the drop-down list.

For more information about debugging your program, see the MULTI: Debugging book.

For a quick reference to the commands available in the MULTI Debugger, see the MULTI Quick Debugger Reference card.

• To set a breakpoint ( ), click any of the green breakdots ( ).

• To step to the next line, click (Next (F10)) on the Debugger toolbar.

• To view register values, click (Registers) on the Debugger toolbar.

• To view interlaced output, see the Debugger Cmd (command) pane at the bottom of the window. To view just the output, select the I/O tab.

• To view interlaced assembly and source code, click (Assembly) on the Debugger toolbar.
If your debug device is not listed, click (Create a new Connection Method) and enter any appropriate information.

5. Click (Edit the selected Connection Method) and review the information to verify that this Connection Method is configured correctly for your board setup. Double-check the connection type and name (or address), and any other relevant settings. Click OK when all of the settings are correct.

6. Click Connect to connect to your target hardware.

You are now ready to debug your program on your target board.

Once you are finished debugging, click to disconnect from your target hardware and close the MULTI Debugger and the MULTI Builder.

For more information about connecting to a target, see Chapter 3, “Connecting to Your Target” in the MULTI: Debugging book.

## Setting Up a Workspace

MULTI workspaces allow you to easily associate actions with a project and perform those actions from within the Launcher. You will now create a workspace and an action sequence for your Hello World project.

### Creating a Workspace

To create a workspace for your Hello World project, perform the following steps:

1. Switch to or start the Launcher.
2. Select File → Create Workspace to open the Select Workspace Type dialog.
3. Enter “Hello World” in the Name field.
4. Select Existing Project and click OK to open the Choose a project dialog.
5. Select the default.gpj file for the Hello World project you created above and click Choose. The default location for projects is:

   • (Windows) — 
     C:\Documents and Settings\username\MyProjects\Projectn
   • (UNIX) — ~/MyProjects/Projectn

Your new workspace will open automatically in the Launcher.

**Adding Actions**

Workspace actions are grouped into action sequences. Your new workspace contains a single action sequence, Startup, which in turn contains an action that opens your project in the MULTI Builder.

Follow the steps below to add additional actions that will connect to your hardware target and open your program in the MULTI Debugger:

1. Right-click the Startup action sequence and select Add Action in the shortcut menu.
2. Select Connection in the Action drop-down list.
3. Select your hardware target connection method in the **Target** drop-down list and click **OK**.

4. Right-click the **Startup** action sequence and select **Add Action** in the shortcut menu.

5. Select **Debug Program** in the **Action** drop-down list.

6. Select your **hello** executable in the **Prog** drop-down list and click **OK**.

The **Startup** action sequence in your workspace now contains three actions, one each of type **Builder**, **Connection**, and **Debug Program**. Whenever you run the **Startup** action sequence these actions will be performed, and MULTI will open your project in the MULTI Builder, connect to your target, and open your program in the MULTI Debugger.

Run the **Startup** action sequence by clicking the button and selecting **Hello World: Startup**.
For more information about workspaces, see Chapter 5, “Using MULTI Workspaces and Shortcuts” in the MULTI: Editing Files and Configuring the IDE book.

Additional Examples

The New Project Wizard contains numerous example projects which highlight particular features of the MULTI Debugger. To access these examples, perform the following steps:

1. Switch to or start the Launcher.
2. Click \( \text{Create Project} \).
3. Select the configuration corresponding to your target board. Click Next.
4. Select one of the example projects in the Project type list. The Example (Basic Debugging) project is a good place to start. Click Finish.
5. Build the project and open it in the MULTI Debugger.
6. Follow the directions in the Cmd pane which will lead you through the example.
Index

A
adding actions to workspaces, 27

B
breakpoints
setting, 25
building projects, 22

C
connecting to a simulator, 24
connecting to hardware, 25
context-sensitive help, 7
covnventions, typographical, 9
creating projects, 20
creating workspaces, 26

D
Debugger
starting, 23
using, 24
document set, 6

F
F1 key, for help, 7

H
hardware
connecting to, 25
help, see online help
Help menu, 7
HP-UX

I
installation
UNIX, 15
Windows, 14
Integrated Development Environment (IDE), see MULTI Integrated Development Environment (IDE)
interlaced assembly
viewing, 25

L
Launcher, see MULTI Launcher
licensing overview, 17
Linux
system requirements, 12

M
MULTI
starting, 20
MULTI Integrated Development Environment (IDE)
document set, 6
online help, 7
overview, 2
MULTI Launcher
overview, 4

N
New Project Wizard, 20
Index

O
online help
  Help menu, 7
  overview, 7
UNIX systems, 8
Windows systems, 7

P
programs
  stepping into, 24
projects
  building, 22
  creating, 20

R
registers
  viewing, 25
requirements
  HP-UX, 13
  Linux, 12
  Solaris, 13
  Windows, 12

S
setting breakpoints, 25
simulator
  connecting to, 24
Solaris
  system requirements, 13
starting MULTI, 20
starting the Debugger, 23
stepping into programs, 24
system requirements
  HP-UX, 13
  Linux, 12
  Solaris, 13
  Windows, 12

T
typographical conventions, 9

U
UNIX
  installation, 15
  using the Debugger, 24

V
viewing interlaced assembly, 25
viewing registers, 25

W
Windows
  installation, 14
  system requirements, 12
workspaces
  adding actions to, 27
  creating, 26
  overview, 5